dunecontrol errors out for suggested module available in wrong version
I tried to build my modules in my home directory with dune-common, dune-istl, dune-geometry, and dune-grid in version 2.4.2. I have pdelab and all dune-modules (version 2.5) it depends on installed in the system path. Now one of the modules that I want to build suggests localfunctions that is not available in the build tree but only as version 2.5 in the system installation path.
In this situation dunecontrol print the errors:
ERROR: version mismatch. dune-localfunctions requires dune-geometry >= 2.5.0, but only dune-geometry = 2.4.2 is available. Execution of dunecontrol terminated due to errors!
which is very unfortunate.