use `std::array` instead of removed `Dune::array`

6 jobs for <span class="ref-name">bugfix/use-std-array</span> in 18 minutes and 52 seconds (queued for 2 seconds)
Status Job ID Name Coverage
  Test
passed #20037
duneci
debian:10 gcc:c++17

00:11:27

failed #20040
duneci
debian:8--gcc

00:00:16

passed #20039
duneci
debian:9--clang

00:11:27

passed #20038
duneci
debian:9--gcc

00:10:23

passed #20042
duneci
ubuntu:16.04--clang

00:08:44

passed #20041
duneci
ubuntu:16.04--gcc

00:09:42

 
Name Stage Failure
failed
debian:8--gcc Test There is an unknown failure, please try again
CMake Error at CMakeLists.txt:5 (cmake_minimum_required):
CMake 3.1 or higher is required. You are running version 3.0.2


-- Configuring incomplete, errors occurred!
See also "/duneci/modules/dune-common/build-cmake/CMakeFiles/CMakeOutput.log".
--- Failed to build dune-common ---
Terminating dunecontrol due to previous errors!
ERROR: Job failed: exit code 1