#1619 Minimal required CMake version
|Reported by||Christoph Grüninger (firstname.lastname@example.org)|
|Reported at||Apr 17, 2015 07:52|
|Version||Git (pre2.4) [cmake]|
|Operating System||Unspecified / All|
With Dune 2.4 we promise to stay compatible with CMake 2.8.6 which was released in October 2011. You can find the complete list of release dates at .
In contrast to Autotools, CMake barely has external dependencies, it is easy to build locally, and Kitware provides binaries that work out of the box . We wanted to limit the support for older compiler versions with Dune 3.0. I'd like to discuss the minimal required CMake version for Dune 3.0.
I propose to go with CMake 3.0. This will be part of Debian "Jessie" 8. Please keep in mind that Dune 3.0 probably won't be released in 2015.