Commit bb1e62af authored by Jö Fahlke's avatar Jö Fahlke

Try to use the old ALUGrid-1.50 tarball I had lying around

I thought I was using ALUGrid 1.52, a it seems I was mistaken and that version
does not exist?

Also, the history of dune-alugrid from pre-dune times appears to be messed up,
it seems different branches (1.50 and 1.93) have been mixed together...
parent 08c98874
Pipeline #20626 failed with stage
in 7 minutes and 57 seconds
......@@ -14,13 +14,12 @@ build:
git
libtool
pkg-config
- ( cd dune-alugrid && ./autogen.sh )
- ( cd dune-alugrid && ./configure --prefix="$(pwd)/alugrid-inst" )
- make -C dune-alugrid -j${DUNECI_PARALLEL:-$(nproc)} install
- echo "CONFIGURE_FLAGS=--with-alugrid=$(pwd)/alugrid-inst" >opts
- dune-common/bin/dunecontrol --opts=$(pwd)/opts --module=dune-pdelab
- tar -xzf ALUGrid-1.50.tar.gz
- ( cd ALUGrid-1.50 && ./configure --prefix="$CI_PROJECT_DIR/ALUGrid-inst" )
- make -C ALUGrid-1.50 -j${DUNECI_PARALLEL:-$(nproc)} install
- dune-common/bin/dunecontrol --opts=$CI_PROJECT_DIR/opts --module=dune-pdelab
autogen ':' configure ':' make -j${DUNECI_PARALLEL:-$(nproc)}
- dune-common/bin/dunecontrol --opts=$(pwd)/opts --only=dune-pm
- dune-common/bin/dunecontrol --opts=$CI_PROJECT_DIR/opts --only=dune-pm
autogen ':' configure
- make -C dune-pm/dune -j${DUNECI_PARALLEL:-$(nproc)}
- make -C dune-pm/lib -j${DUNECI_PARALLEL:-$(nproc)}
......
......@@ -16,9 +16,6 @@
[submodule "dune-typetree"]
path = dune-typetree
url = ../../staging/dune-typetree.git
[submodule "dune-alugrid"]
path = dune-alugrid
url = ../../extensions/dune-alugrid.git
[submodule "dune-pdelab"]
path = dune-pdelab
url = ../../pdelab/dune-pdelab.git
......
Subproject commit cfe6f946099d644b1a2750dc01714be2845b12f8
CONFIGURE_FLAGS="--with-alugrid=$CI_PROJECT_DIR/ALUGrid-inst"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment