Commit 10b4ad7e authored by Christian Engwer's avatar Christian Engwer

Merge branch 'feature/update-test-environments' into 'master'

Update test environments

- No longer test with clang 3.5.
- Add clang 3.8 from Debian 8 + backports
- Add gcc 5.4 + clang 3.8 from Ubuntu 16.04 LTS.
- Use `duneci-standard-test`

See merge request !18
parents ac9a737f 20f82cc5
......@@ -4,28 +4,24 @@ before_script:
debian:9--gcc:
image: duneci/base:9
script:
- dunecontrol --current --opts=/duneci/opts.gcc all
- dunecontrol --current make build_tests
- cd build-cmake; duneci-ctest
script: duneci-standard-test
debian:9--clang:
image: duneci/base:9
script:
- dunecontrol --current --opts=/duneci/opts.clang all
- dunecontrol --current make build_tests
- cd build-cmake; duneci-ctest
script: duneci-standard-test --opts=/duneci/opts.clang
debian:8--gcc:
image: duneci/base:8
script:
- dunecontrol --current --opts=/duneci/opts.gcc all
- dunecontrol --current make build_tests
- cd build-cmake; duneci-ctest
script: duneci-standard-test
debian:8--clang:
image: duneci/base:8
script:
- dunecontrol --current --opts=/duneci/opts.clang all
- dunecontrol --current make build_tests
- cd build-cmake; duneci-ctest
debian:8-backports--clang:
image: duneci/base:8-backports
script: duneci-standard-test --opts=/duneci/opts.clang
ubuntu:16.04--gcc:
image: duneci/base:16.04
script: duneci-standard-test
ubuntu:16.04--clang:
image: duneci/base:16.04
script: duneci-standard-test --opts=/duneci/opts.clang
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment